SAP Knowledge Base Article - Public

3333053 - '|Technical Response: : code : PERIOD_KEY_INVALID,message : Invalid period key HTTP code: 400' Error in VAT Return for UK

Symptom

The submission of VAT Return for UK has failed with the error message:

'|Technical Response: : code : PERIOD_KEY_INVALID,message : Invalid period key HTTP code: 400'

Environment

 SAP Business ByDesign

Reproducing the Issue

  1. Go to the Tax Management work center.
  2. Go to the VAT Returns view.
  3. Open the respective VAT Return.
  4. Click View All.
  5. Under Submission Information section, notice the error:

'|Technical Response: : code : PERIOD_KEY_INVALID,message : Invalid period key HTTP code: 400'

Cause

The issue is happening as 2 open period keys are being received from HMRC (Her Majesty's Revenue and Customs, the tax authority of the UK government).

Resolution

Please get in touch with HMRC to check why 2 open period keys and are being sent to SAP Business ByDesign as a response back for VAT obligation API ( get period key ).

In an ideal setting, only one period key with status 'O' is received. In this case, 2 period keys were retrieved, system by default tried to use one of them as the period key and HMRC rejected the VAT submission citing the reason "INVALID_PERIOD_KEY".

In case you are not able to sort out the issue with HMRC, please report an incident to SAP Support with your permission to us to submit the VAT Return via backend system through debugging.

Keywords

VAT return; UK; MTD; HMRC; period key; period keys , KBA , SRD-FIN-GLO-TAX , GLO - Tax Declaration , How To

Product

SAP Business ByDesign all versions