Symptom
Some users receive no data but an error message when clicking the Owner field overview value list button.
Environment
Product version: SAP Sales Cloud and SAP Service Cloud Version 2 1.0
Reproducing the Issue
- In any object, such as Call Lists, Leads, etc.
- Click New
- Select owner field list
Cause
Clicking the owner ovs pulls a list of employees. However, the user does not have access to the employee service.
Resolution
Please add the employee access rights for the user's business role(s).
- Go to: Settings > Business Roles > find and open the relevant business role.
- Under the Details tab:
- Add service Employee - sap.crm.md.service.employeeService
-
Add the relevant app, depending on whether the role is amin or not (i.e.: sap.crm.md.employeeservice.uiapp.employeeApp or sap.crm.md.employeeservice.uiapp.employeeNonAdminApp )
- Reload the system for the user and retry.
See Also
Full error, taken from internal system:
Error fetching employee from server: Error: HttpErrorResponse: 403(OK), Http failure response for https://XXXXXXXXX.crm.cloud.sap/elsa/sap/c4c/api/v1/employee-service/employees?$filter=(employeeTypes/validFrom%20le%202023-05-12%20and%20employeeTypes/validTo%20ge%202023-05-12)&$select=attachments,displayId,employeeDisplayId,externalIds,formattedName,id,managerEmployeeDisplayId,managerFormattedName,managerId,organizationalUnitDisplayId,organizationalUnitId,organizationalUnitName&$count=true&$top=30&$orderby=formattedName%20asc&thumbnailSize=M: 403 OK
dev tools:
-
Request URL:
-
Request Method:GET
-
Status Code:403
Response:
{
"error": {
"message": "Access to resource is unauthorized. Verify and try again."
}
}
Keywords
KBA , CEC-CRM-CALL , Call Lists for SAP Sales/Service Cloud , CEC-CRM-EMP , Employee for SAP Sales/Service Cloud , Problem