SAP Knowledge Base Article - Public

3333522 - Custom party roles do not get redetermined in Tasks

Symptom

 Custom party roles do not get redetermined in Tasks

Environment

SAP Cloud For Customer

Reproducing the Issue

Prerequisites:

  1. You have a custom party role (Z11 for example) added in the Account Team Facet of the Account
  2. You have maintained the determination, 'Z11 of Account Team' for the same party role Z11 in 'Maintain Involved Parties For Tasks'

Steps to Reproduce:

  1. Go to Customer Workcenter
  2. Go to Accounts Workcenter View
  3. Open any Account
  4. Go to Account Team Facet
  5. Add the party role Z11 and assign a user (ABC for example)
  6. Create a Task from the Account by clicking the New button in the 'All Tasks' section present in Activities Facet
  7. The party role and respective user is seen in the Involved parties section in Overview Facet
  8. Now, change the business user for the same party role Z11 in the Account Team facet from ABC to DEF
  9. Now, make a dummy change in the Task created

Result: The party role Z11 in the task still shows user ABC and not DEF.

Cause

This is the current system behaviour. The party role determination can be seen in Opportunities BO, Tickets BO etc., if configurations are maintained correctly, but not for Activities such as Task.

Resolution

 This is the current system behaviour.

See Also

Keywords

Party role, Activities, Task, Redetermination , KBA , LOD-CRM-ACT , Activities , LOD-CRM-ACC , Account , Problem

Product

SAP Cloud for Customer core applications all versions