SAP Knowledge Base Article - Public

3333665 - Service ticket document flow is not showing

Symptom

You cannot see the desired document under Document Flow facet for tickets in C4C when integrating with S/4.

Environment

  • SAP Cloud for Customer
  • SAP S/4 HANA 

Reproducing the Issue

  1. You find Document Flow in C4C is not showing up the desired Document.
  2. You find Output type COD1 is failing in S/4 due to the missing RCOD_OUTPUT_COD1.

Cause

RCOD_OUTPUT_COD1, RCOD_OUTPUT_COD3, and RCOD_GENERATE_SUCCESSOR_DOC programs are not required for S/4HANA integration with C4C.

Resolution

This is an epxected system behavior. The service ticket follow-up is delivered through either the iFlow Notify Service Ticket of Follow-Up Document from SAP Business Suite or the Notify Ticket of Follow-Up Document from SAP Business Suite, depending on your S/4 release. Once the inbound IDOC is processed, an automatic confirmation IDOC is generated. You may refer to the function module COD_IDOC_SERVICE_CONF_W_LOGS for more information. To send confirmation IDOC the required partner profile settings should be in place.

Keywords

COD1, COD3, RCOD_OUTPUT_COD1, RCOD_OUTPUT_COD3, RCOD_GENERATE_SUCCESSOR_DOC, Document Flow, COD_IDOC_SERVICE_CONF_W_LOGS , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , How To

Product

SAP Cloud for Customer core applications all versions