Symptom
In a Sales Order after simulating external pricing with two or several Sales Kits items they do not display correctly under parent item.
Environment
Cloud for Customer
Reproducing the Issue
- Go to the Sales workcentre in Cloud for customer and into Sales orders.
- Open an order which has two or more BOM materials maintained.
- Click on actions and simulate.
- Observe that the items appear out of order as children items don't display under their parent item.
Cause
The payload that is generating IDs for the items is generating them out of order. The items are then displayed in the order in the order of these IDs with the smallest at the top and largest ID at the bottom.
Resolution
This is due to the item increment value being too small for all the items to be generated correctly.
To solve this issue you can increase the item increment by following the below steps.
- Go to the Business Configuration work center.
- Go to the Overview view.
- Search for the fine-tuning activity for Sales Order/ Sales Quote.
- Enter Maintain Document types.
- Change the Item Increment to a larger value such as 100.
- You then may need to re add the items to the sales order.
Keywords
cloud for customer, sales order, order, external pricing, BOM, materials, items , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem