Symptom
In a Follow-up document created from a Sales Quote or Service Quote, you notice that there is no Tax Exemption Certificate maintained, but the checkbox is marked regardless.
Environment
SAP Business ByDesign
Reproducing the Issue
Using a Service Quote and Service Order as an example:
- Go to the New Business work center.
- Open the Service Quotes view.
- Find Service Quote ABC (Where ABC Represents the Service Quote ID).
- Open the document and click on View All.
- Navigate to the Service and Spare Parts tab.
You see that no items in the Quote have a Tax Exemption Certificate maintained. If you open the Account used in the Quote, no Tax Exemption Certificate is present in the Account either.
- Navigate to the Document Flow tab of Service Quote ABC.
- In the Document Flow tab, open Service Order DEF (Where DEF Represents the ID of the Service Order generated as a Follow-Up from the Service Quote).
- Click on View All.
- Navigate to the Service and Spare Parts tab.
You see that the Tax Exemption Certificate checkbox is marked, with no Tax Exemption Certificate ID maintained.
The same is also true for subsequent documents created such as Customer Invoices.
Cause
In this scenario, this is a visual issue in the UI that does not impact the Tax Calculation process at all. It is caused by an older behaviour for Tax Countries which have Tax Exemption Certificates enabled. The checkbox used to be marked even in cases where the Tax Exemption Certificate was not picked up.
This scenario also applies for Sales Quotes and Sales Orders.
Resolution
This visual issue only happens when a Quote is involved in the scenario. The development team understands that this is a usability issue and has taken this up as an issue to be fixed in a future release of the system in order to harmonize the behaviour of the Tax Exemption Certificate checkbox for all scenarios.
Keywords
Sales Quote, Service Quote, Tax Exemption Certificate, TEC, Exempt, Inconsistent, Checkbox, Marked, Checked, , KBA , AP-TTE-TC , Tax Calculation , Problem