Symptom
You created a Workflow Rule for example for the Business Object Sales Order with the Type E-Mail and maintained the Recipient Determination as Processor, but the Employee Responsible does not receive the E-Mail.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Application and User Management work center.
- Select the Workflow Rules view.
- Open the Rule ABC (ABC represents the description of the rule).
- Navigate to the Define Actions step.
- You selected the Rule Type E-Mail maintained all the relevant data and entered in the Recipient Determination the determination Processor.
Since in our example we are using a Workflow Rule for the Business Object Sales Order you expect that the E-Mail is set to the E-Mail Address of the Employee Responsible in the Sales Order if the Sales Order is created/changed and the parameters set up in the rule are met.
However, the Employee Responsible does not receive the E-Mail eventhough the Employee has a valid E-Mail Address maintained.
Cause
The Business User of the Employee Responsible is not valid.
Resolution
- Go to the Application and User Management work center
- Select the Business User view
- Search for the respective user.
Ensure that the user is valid.
Keywords
Workflow Rule; E-Mail; Recipient; not received; not sent , KBA , SRD-CRM-ORD , Orders & Contracts , Problem