Symptom
You are making OData API calls to some SuccessFactors (SF) endpoint/address using Basic authentication but the error is being thrown:
"Unable to authenticate the client (Login failed - account locked)"
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Make an OData API call to SF providing API user credentials;
- See the error message;
Cause
This error message indicates the API user is locked in SuccessFactors.
This usually happens when there are some login attempts with wrong password.
Resolution
To solve it you just need to unlock the API user in SuccessFactors following the KBA 2086751 - How to Unlock a User Who Has Been Locked Out - SuccessFactors.
See Also
Keywords
API user, credential, credentials, wrong, different, incorrect, password, login, attempt, attempts, lock, locked, blocked, unable, unlock, set , KBA , LOD-SF-INT-ODATA , OData API Framework , Problem