Symptom
You are integrating your SuccessFactors instance with other system (client) using APIs and OAuth2 authentication, but an error message is being thrown:
"Unable to verify the signature of the SAML assertion. Please ensure that the assertion has a signature and the key pairs match the client ID"
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
-
Register your client application in SuccessFactors;
-
Obtain an SAML assertion;
-
Try to generate an OAuth token;
- See the error message;
Cause
There are some possible reasons for that:
- Incorrect Key Pair (public and private key);
- Incorrect or nonexistent SAML assertion signature;
Resolution
There are different resolutions for each cause:
- Check if the public key being used corresponds to the public part of X-509 Certificate in your client application in SuccessFactors (under Manage OAuth2 Client Applications);
Check if the private key (Client Secret) being used corresponds to the private part of X-509 Certificate generated and downloaded in your client application in SuccessFactors; - Ensure that the assertion has a signature or generate a new SAML assertion (refer to Generating a SAML Assertion from OData guide);
See Also
- KBA 2850646 - How to register for OAuth 2.0 authentication - SuccessFactors Integrations
- Authentication Using OAuth 2.0 chapter from OData guide;
Keywords
incorrect, wrong, key pair, public, private, api, key, certificate, client ID, client secret, client, server, application, applications, signature, 401 , KBA , LOD-SF-INT-ODATA-OAU , ODATA OAUTH Authentication , LOD-SF-INT-API , API & Adhoc API Framework , Problem