Symptom
You have noticed that, upon requesting a Workflow that has two approvers (at least), one of them is receiving an e-mail notification to approve it and the other person - who shares the first approval step, for example - isn't receiving it;
You have configured or edited the e-mail template correctly on the Email Notification Settings tool, as highlighted on the Guide articles Defining Workflow Email Notifications | SAP Help Portal and Editing Standard Templates | SAP Help Portal.
Environment
- SAP SuccessFactors Employee Central
- SAP SuccessFactors HXM Suite
Reproducing the Issue
- Request a change that has a Workflow assigned;
- Observe that only one of the approvers has received the e-mail notification.
Cause
- On the Workflow configuration, you have selected the 'Approver Type' as 'Position Relationship'. By default, the system will query the database and assign whichever incumbent is returned first by the system;
- If the Position is a Mass Position (2 or more users assigned to it) and this Position has Direct Reports (DR), the first Incumbent of the Mass Manager Position that is returned by the system will be used as the Manager for the incumbents of the lower level positions.
Resolution
If you would like to all approvers to receive e-mail notifications, you will need to create a Dynamic Group and assign it as the 'Approver Type' of the Workflow. You can reference the Guide article Creating a Dynamic Group | SAP Help Portal to understand how to do so.
See Also
Keywords
workflow, email notification, email, not receiving, not, receiving, time off, position, employee central, mass position, position relationship, dynamic group, , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-EC , Employee Central , LOD-SF-EC-TIM , Time Off , LOD-SF-EC-POS , Position Management , LOD-SF-EC-POS-WFL , Position Workflows , LOD-SF-EC-TIM-WAN , Workflows - Alerts - Notifications , Problem
SAP Knowledge Base Article - Public