SAP Knowledge Base Article - Public

3337480 - No new version is created In the 'Manage Documents' app when using the Check in option 'Check-in as New Version'

Symptom

No new version is created In the 'Manage Documents' app  when using the Check in option 'Check-in as New Version'

Environment

  • SAP S/4HANA, Cloud
  • Document Management ( DMS )

Reproducing the Issue

  1. Open Manage Documents app
  2. Navigate to the Details screen of a Document Info Record
  3. Click on Originals tab
  4. Press Edit button
  5. Select an Entry under Attachments tab
  6. Press Check-out button
  7. Select Entry under Attachments tab
  8. Press button 'Check-in' as 'Check-in New Version'
  9. Attached a new PDF
  10. Save

   No New Version is created for the Document Info Record

Cause

With Document Management -> Document Edit -> Check out -> 'Check in as new version' - The expected behavior of this functionality is to create a new version of the attachment and update with the latest attachment(Old attachment will be deleted).

This feature does not create a new Document(Document Info record) version.

Resolution

To create a new version of the Document(Document Info record) you need to click on the 'Create New Version' button from the  Manage Documents App object page.

Keywords

KBA , PLM-FIO-DMS , Fiori UI for Document management , CA-DMS , Document management , How To

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions