Symptom
No new version is created In the 'Manage Documents' app when using the Check in option 'Check-in as New Version'
Environment
- SAP S/4HANA, Cloud
- Document Management ( DMS )
Reproducing the Issue
- Open Manage Documents app
- Navigate to the Details screen of a Document Info Record
- Click on Originals tab
- Press Edit button
- Select an Entry under Attachments tab
- Press Check-out button
- Select Entry under Attachments tab
- Press button 'Check-in' as 'Check-in New Version'
- Attached a new PDF
- Save
No New Version is created for the Document Info Record
Cause
With Document Management -> Document Edit -> Check out -> 'Check in as new version' - The expected behavior of this functionality is to create a new version of the attachment and update with the latest attachment(Old attachment will be deleted).
This feature does not create a new Document(Document Info record) version.
Resolution
To create a new version of the Document(Document Info record) you need to click on the 'Create New Version' button from the Manage Documents App object page.
Keywords
KBA , PLM-FIO-DMS , Fiori UI for Document management , CA-DMS , Document management , How To