Symptom
Error "Enter valid Description Language code" to import Warranties.
Environment
- SAP Service Cloud v2
- SAP Sales Cloud v2
Reproducing the Issue
- Open All Settings.
- Enter the Monitoring screen.
- Click on import button.
- Select Warranty entity.
- Make sure Complete entity checkbox is marked.
- Select the file type and upload the zip file.
- Click on Import data.
- Result: You see that status is COMPLETED_WITH_ERRORS and when you open the error file you see "Some input values are invalid :- { Enter valid Description Language code }".
Cause
You filled an invalid language code in the Warranty_Descriptions file. The field is case-sensitive so if you fill as "EN" the error will be triggered.
Resolution
Fill the language code with a valid (lower case) value (e.g: en). You can check all the possible codes by following below steps:
- Open All Settings.
- Enter the Monitoring screen.
- Click on Download Template button.
- Select Warranty as entity.
- Mark the complete entity checkbox.
- Click on download template.
- Open the zip file.
- Open the file Code_languageCode. Here you will be able to check all the possible values for the language code field.
Keywords
Warranty, Import, Completed with Errors, Language code , KBA , CEC-CRM-IMX , Data Import/Export for SAP Sales/Service Cloud , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 1.0