SAP Knowledge Base Article - Public

3337864 - Custom Email notification is not triggering - Onboarding

Symptom

A Custom Email notification has been created, and business rule to trigger email notification, however email is not triggering. Possible scenarios:

 

Environment

SAP SuccessFactors Onboarding

Cause

  • Trigger condition is out of the box for which Category has been used. Therefore, the wrong "Data Source" is being used in the Rule created to trigger the custom email.
  • Once Recipient Builder / Content Builder is different than the ones selected in Guides as example, Data Source will be different as well.

Resolution

(Scenario for example) Custom email was created as the following:

  • Template Title: (ONB) Custom_Email EXAMPLE
  • Trigger condition: (ONB) Prepare for New Team Member Trigger
  • Category: (ONB) NHA Category

"(ONB) Prepare for New Team Member Trigger" is out of the box trigger for which category is "(ONB) NHA Category". For "(ONB) NHA Category" data source is Activity and not Process Task. However in the created Rule, Data Source is as "Process Task".

Please, follow guides and create new Category and Trigger appropriately. 

Important! Select Data source according to the Recipient Builder/Content Builder used on Category. As reference: Business Rules for Triggering Email Notifications | SAP Help Portal

See Also

Custom Email Notification Triggers Using Business Rules | SAP Help Portal

Business Rules for Triggering Email Notifications | SAP Help Portal

Creating a Business Rule to Trigger an Email Notification When the New Hire Data Review Step is In Progress | SAP Help Portal

Creating a Business Rule to Trigger an Email Notification When the Manage Pending Hire Step is in the Ready to Hire Status | SAP Help Portal 

Keywords

custom, email, trigger, not, show, showing, onboarding, rule, MPH, NHDR , KBA , LOD-SF-OBX-EML , Notifications , Problem

Product

SAP SuccessFactors Onboarding all versions