SAP Knowledge Base Article - Public

3338108 - Cancellation Event Reason not populating in Business Rules - Onboarding

Symptom

  • The client wants to send a cancel notification only if the event reason is a No Show and a stop notification if cancellation is to rehire the candidate.
  • A business rule was configured and the rule is not seeing the cancellation reason and event reason that has been set during the cancel transaction. 

Environment

SAP SuccessFactors Onboarding

Cause

Product Defect:

  • The cancel notification template rule is not seeing the cancellation reason and event reason that has been set during the cancel transaction.
  • Due to this, clients are unable to stop notifications based on Event Reasons.
  • The behavior is not consistent - as it is depending on the notification delay time. If the notification is processed after the cancel transaction is committed, then the notification is working as expected.

Resolution

WORKAROUND? There is no common workaround available.

  • We need to depend on any employee details if applicable to differentiate whether the candidate process is getting cancelled for Rehire use case or it is a proper No Show scenario.

PERMANENT FIX: OBX-26590

  • The Engineering Team has introduced a code correction to fix the issue and is scheduled to be deployed on 2H 2023 (b2311) release.
  • The standard Roadmap disclaimer applies.

Keywords

OBX-26590, Cancel Onboarding, Cancellation Evert Reason, business rule, No Show, Rehire, Cancellation Reason, INC4267784, Email, Cancel notification, ONB, ONB2, OBX, Onboarding , KBA , LOD-SF-OBX-CAN , Cancel Onboarding , Problem

Product

SAP SuccessFactors Onboarding 2211