SAP Knowledge Base Article - Public

3338117 - Error is being received and unable to complete US I-9 Section 2 for a candidate - Onboarding

Symptom

  • Responsible users cannot complete US I-9 Section 2 for candidate.
  • Error Message: [COE0019]todo task unavailable for task category: ONBOARDING2_HIRINGMANAGER_I9_PAPERWORK and BPE process id:complianceProcessId

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Login to the instance
  2. Proxy as the responsible user for US I9 Section 2 of the candidate
  3. Go to Onboarding > search for the candidate
  4. Click Start for the US I9 Section 2
  5. The error appears.

Cause

There are two tasks for the new hire:

  • Complete Form I-9 Section 2
  • Correct Form I-9 Data.

Defect:

  • When I-9 Section 1 data correction is initiated, we do not update compliance process task status, which leads to a situation when both sections 1 and 2 tasks are showing in the dashboard the Section 2 task remains open. 

 

Resolution

WORKAROUND: 

  • The team (engineering) can manually update the status of the Section 2 task OR you can just ignore it.
  • If there's a Section 1 correction, the new hire has to complete I-9 Section 1 again. Once it's completed, the I-9 Section 2 task will become active and the Start button will begin working.

PERMANENT FIX: OBX-26646

  • A code correction has been created by the Engineering Team and is tentatively scheduled to be deployed on 2H 2023 (b2311) release.
  • The standard Roadmap disclaimer applies.

NOTE!! This KBA will be updated once the mentioned code correction ticket above has been finalized and fixed.

Keywords

OBX-26646, COE0019, ONBOARDING2_HIRINGMANAGER_I9_PAPERWORK and BPE process id:complianceProcessId, Error US I9 Section 2, US I-9, I9, I-9, Compliance, OBX, ONB2, ONB2.0, Onboarding, INC4550446 , KBA , LOD-SF-OBX-I9 , i9 Compliance Form , Bug Filed

Product

SAP SuccessFactors Onboarding 2211