SAP Knowledge Base Article - Public

3338409 - Administrator unable to see results on search

Symptom

Certain administrators are unable to see some results on Learning Administration searches.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. Access Learning Administration >
  2. Navigate to any entity search (i.e curricula) >
  3. Search by curricula title >
  4. Some administrators are missing results that are displayed to other administrators with the same level of permission.

Cause

The locale selected for the affected administrator is English instead of English United Kingdom under Preferences and the entity title is only available on English United Kingdom locale.

Administrator affected by search result issue:

Administrator not affected by search result issue:

Resolution

  • Adjust the Locale ID in the administrator preferences so it matches the locale where the entity's title is available.
  • Add a title to the entity corresponding to the locale used by the administrators.

Keywords

learning, lms, administrator, search, results, missing, not, found, title, description, locale, translation, english, united, kingdom, curricula, item, class, program, library, content , KBA , LOD-SF-LMS-ADM , System Admin, Global Variables, References , LOD-SF-LMS-WOR , Roles & Workflows , Problem

Product

SAP SuccessFactors Learning all versions

Attachments

affected_admin.png