Symptom
The KUT field in the TI is not updated in C4C, despite relevant information being present in the inbound payload in Admin -> Webservice Message Monitoring.
Environment
- SAP Cloud for Customer
Reproducing the Issue
- Access Admin -> Webservice Message Monitoring.
- Observe that two messages are generated during the employee replication process in C4C: one under the service interface EmployeeReplicationIn and the other under EmployeeCentralEmployeeReplicationIn.
- Note that the KUT field information is only available within the EmployeeCentralEmployeeReplicationIn message.
- Open the replicated employee record and verify that the KUT field in the TI remains unaltered.
Cause
The KUT field in the EmployeeCentralEmployeeReplicationIn messages' PersonalDetails node does not update the TI's KUT field.
Resolution
Send KUT field under common node of messages under service interface EmployeeReplicationIn.
See Also
Keywords
EmployeeCentralEmployeeReplicationIn, EmployeeReplicationIn, EmployeeCentralEmployeeReplicationRequest, EmployeeReplicationRequest, Common, PersonalDetails , KBA , LOD-CRM-EMP-RPL , Employee Replication , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem