Symptom
- When changing multiple entities via Manager Self-Service (MSS) for example Job Information and Compensation Information, changes made by onSave rules in the second entity e.g. Compensation Information are not considered when Job Information onSave Rules are processed, when Enable Centralized Services to Save Changes on the Manager Self-Service UI for Change Job and Compensation Info is enabled.
- You may see an impact of this with Workflow and Event Reason Derivation Rules, where the wrong Event Reason and/or the wrong/no workflow is being triggered.
Environment
- SAP Successfactors HXM Suite
- SAP Successfactors Employee Central
Cause
This issue is due to the rule logic processing when Enable Centralized Services to Save Changes on the Manager Self-Service UI for Change Job and Compensation Info is enabled.
Note: The switch "Enable Centralized Services to Save Changes on the Manager Self-Service UI for Change Job and Compensation Info" is no longer available as it is universally applied by default there is no way to disable it.
Previously when changing multiple entities in the same transaction, onSave Business Rules were triggered twice.
This is not the correct logic and so with Centralized Services this logic has been improved to only run rules once.
What does this mean for me?
This may lead to a change in behavior with rules processing especially in Event Reason and Workflow Derivation, when a value is set by a Compensation Information Rule but is checked in a Job Information Rule which is deriving Event Reason or Workflow Derivation.
Resolution
To resolve the issue an amendment to your impacted rules may be needed.
This will require updating the Job Information rule to ensure the data is available to process when deriving Event Reasons and Workflows.
Please note that this feature "Enable Centralized Services to Save Changes on the Manager Self-Service UI for Change Job and Compensation Info" is universal in 2H 2023 and can't be disabled.
Examples:
Example 1: Field Value is set in Compensation Information via an OnSave rule, same value is checked as part of Job Information Workflow Derivation and Event Reason Derivation Rules.
Scenario:
There is a custom field on Compensation Information which is updated with the New Salary of a user after an update to their Pay Components. When deriving the Event Reason and Workflow Derivation the New Salary Field is checked to see if there is a change and if the new value is greater than the previous, to set a specific Event Reason and Workflow.
Rule to Set the New Salary:
Rule which sets Event Reason Derivation and Workflow Derivation:
- In the first If Condition we are checking to see if the New Salary Value is Greater than the Previous Value, if so the Event Reason Promotion w/ Pay Change >5% is set and Workflow Pay Rate Change > 5% is triggered.
- In the Second If Condition we are checking to see if the Current Salary is not equal to Null, if so the Event Reason Promotion – No Pay Change is set, and the Workflow Promotion is triggered.
Test:
Derivation test when the following is DISABLED: Enable Centralised Services to Save Changes on the Manager Self-Service UI for Change Job and Compensation Info.
- Change a user’s Annualized Salary to a greater value, the Rule to set the New Salary is Triggered
- The Event Reason Derivation and Workflow Derivation Rule is triggered:
Event Reason Promotion w/ Pay Change >5% is set and Workflow Pay Rate Change > 5% is triggered.
Derivation test when the following is ENABLED: Enable Centralised Services to Save Changes on the Manager Self-Service UI for Change Job and Compensation Info.
- Change a user’s Annualized Salary to a greater value, the Rule to set the New Salary is Triggered
- The Event Reason Derivation and Workflow Derivation Rule is triggered:
Promotion – No Pay Change is set and the Workflow Promotion is triggered.
This is because of the logic change with Centralized Services, as described above.
Required Changes:
Please note it is recommended to first make the changes in a non-Production Instance and to test the rules are working correctly before moving to your Production Instance. You can use the workaround of turning off the ‘Enable Centralized Services to Save Changes on the Manager Self-Service UI for Change Job and Compensation Info’ setting in Company System and Logo Settings, until you are ready to make the changes in your Production Instance. Please note this workaround will not be available in the 2H 2023 release as this feature will be universally enabled.
- This will require updating the Job Information rule to ensure the data is available to process when deriving Event Reasons and Workflows.
- Please Note while making the required changes we also encourage you to ensure you are using best practices for Event reason and Workflow Derivation Rules.
In the above example there are three issues with the derivation rule:- The Rules are created on Basic Scenario, this is not recommended. We recommend you use the Event Reason Derivation and Trigger Workflows scenario for the relevant rules.
- It is not recommended to set Event Reasons and Workflows in the same rule.
- It is recommended to checked if Event Reason field’s value is null before setting it through a business rule.
- Below we will show you how to correct the above rule example, to set the desired Event Reasons and Workflows and comply with the rule best practices.
- We will first Create an Event Reason Derivation Rule. This will be done using the Event Reason Derivation Scenario
- In this rule, we will check the same IF conditions for our Compensation Information Rule to ensure we can derive the correct Event Reason:
- Next, we will create a Workflow Derivation Rule. This will be done using the Trigger Workflow Scenario.
- In this rule, we will check the same IF conditions for our Compensation Information Rule to ensure we can derive the correct Workflow:
- We will then disable the original rule and add the two new rules to Manage Business Configuration on jobInfo:
- Now when testing the Event Reason and Workflow Derivation the desired values are set with and without ‘Enable Centralised Services to Save Changes on the Manager Self-Service UI for Change Job and Compensation Info’ setting in Company System and Logo Settings (Not applicable in 2H 2023 release as this feature is universally enabled and can't be disabled).
FAQ:
Q: How do I know if I am impacted by this?
A: If you are getting an incorrect Event Reason and/or Workflow when the following is enabled: ‘Enable Centralised Services to Save Changes on the Manager Self-Service UI for Change Job and Compensation Info’ setting in Company System and Logo Settings. Please disable this setting and test if the desired Event Reason and/or Workflow is set. If so, then your rules will need to be adjusted as described above.
Please note from the 2H 2023 Release Centralised Services to Save Changes on the Manager Self-Service UI for Change Job and Compensation Info is universally enabled and can't be disabled.
Q: Why should we not set Event Reason and Workflows in the same rule?
A: This is not a best practice, and we encourage you to use the designated Rule Scenarios for each type of Derivation Rule. More information can be found on the best practices in the following two sections of the guide:
- Implementing Employee Central Core: Event Reason Derivation Business Rules
- Implementing and Managing Workflows: Triggering Workflows with Business Rules
Q: What happens if I do not update my rules and disable ‘Enable Centralised Services to Save Changes on the Manager Self-Service UI for Change Job and Compensation Info’ setting in Company System and Logo Settings?
A: This can be used as a temporary workaround to allow you time to make the changes in a non-Production Instance and to test the rules are working correctly before moving to your Production Instance. Please note that this feature will be universal in 2H 2023. This means we encourage you to have adjusted the rules before the 2H 2023 release to ensure you are not negatively impacted after the 2H 2023 Release.
See Also
- SAP SuccessFactors What's New Viewer: Centralized Services Support Manager Self-Service Changes to Job Information and Job Relationships
- SAP SuccessFactors What's New Viewer: Centralized Services Support Manager Self-Service Changes to Compensation Information
- Implementing Employee Central Core: Event Reason Derivation Business Rules
- Implementing and Managing Workflows: Triggering Workflows with Business Rules
Keywords
workflow, event reason , ERD, derivation, CS20230005531297, INC4877926, Centralized Services, business rules, , KBA , LOD-SF-EC-JOB-RUL , Job Info Business Rules , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-EC-CMP-RUL , Business Rules , LOD-SF-EC-JOB-EVN , Events, Derivation & Employee Status , LOD-SF-EC-CMP-EVN , Events, Derivation & Employee Status , Problem