Symptom
You have an Inbound Delivery document which is facing a process communication error in the document flow of the document and did not create the Customer Return.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Inbound Logistics work center.
- Select the Inbound Deliveries view.
- Show All Inbound Deliveries.
- Select inbound delivery ABC (ABC represents the ID of the inbound delivery).
- Click on the Edit button and navigate to the Document Flow tab.
- Here you can see the red exclamation mark at the bottom of inbound delivery ABC
- Go to the Application and User Management work center.
- Select the Process Communication Error view.
- Show Open Errors with Incidents.
- Select the sending document Inbound Delivery ABC.
- One of the following errors are displayed:
Main Error: Create not possible; source object inconsistent
Related Errors: Products with item group Product - project based not supported for Customer Return
Or
Error: Inbound Error: BO reference missing or not valid
Error in the Error Log: Products with item group Spare part - direct goods issue not supported.
Or
Inbound Error: BO reference missing or not valid
Products with item group Spare part - consumable issue not supported.
Cause
For the Error: Products with item group Product - project based not supported for Customer Return
The product returned in inbound delivery ABC has the item group PMAT - Product - project based. Currently we do not support the item group PMAT - Product - project based in the Customer Return scenario.
For the Error: Products with item group Spare part - direct goods issue not supported.
The product returned in inbound delivery ABC has the item group DIGI- Direct Goods Issue. Currently we do not support the item group DIGI- Direct Goods issue in the Customer Return scenario.
For the Error: Products with item group Spare part - consumable issue not supported.
The product returned in inbound delivery ABC has the item group CONS - Spare part - consumable. Currently we do not support the item group CONS- Spare part - consumable in the Customer Return scenario.
Resolution
This is the system expected behavior.
If you do not need to use item group PMAT - Product - project based/DIGI- Direct Goods Issue/CONS - Consumable in the return scenario, please change the item group to NORM - Product - delivery-based permanently.
If you do need to use the current maintained item type, please change to NORM temporarily and perform the actions below.
Once the error is resolved, you may chance back to the desired item type.
Once you have completed this action,
- Go to the Application and User Management work center.
- Select the Business Document Differences view.
- Search for Inbound Delivery ABC.
- If the document is displayed, please click on the Start Repeat Check button.
In case the error does not disappear and Start Document Synchronization is available, click on this button.
If none of the options solves the issue, kindly send a ticket for SAP and inform that you have already completed the changes required above.
Keywords
Process Communication Error, Inbound Delivery, Customer Return, Return, Error, Item Type, Business Transaction , KBA , AP-CRP-CR , Customer Return , How To