SAP Knowledge Base Article - Public

3341580 - E-Verify triggered with blank screen - Onboarding

Symptom

E-Verify is coming blank for affected candidate.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Open Onboarding Dashboard / E-Verify Card on Home Page
  2. Select affected candidate
  3. On Form I-9 and E-Verify, click on "E-Verify Case Details"
  4. After loading, page comes as blank.

Cause

Cause 1: E-Verify Case Number of affected candidate is not configured in Manage Data.

Cause 2: Candidate is already hired.

Resolution

Cause 1 - For the affected candidates, you will need their:

  • E-Verify Case number 
  • User ID

Follow steps to resolve the issue:

  1. Go to Manage Data > E-Verify Data
  2. Search for the User Id. Click on the result
  3. Click Take Action > Click Make Correction
  4. On the Case Number field, paste the E-Verify Case Number of affected candidate
  5. After doing the steps above, refresh data on the Candidate's E-Verify Case Details.

Cause 2 - Once candidate is hired he is no longer an External User. E-Verify card will still be available for responsible users assigned to complete this task. However if in their permission role, target population is only for External Users, they won't be able to see the whole page.

To correct it, it's necessary to either grant target population for all reports (externals and internals), or add this user in a role that contains it.

Keywords

everify, e-verify, blank, information, screen, available, candidate, form, Onboarding, OBX, Home, Page, Card, loading , KBA , LOD-SF-OBX-EVF , Everify , Problem

Product

SAP SuccessFactors Onboarding all versions