Symptom
- You are using the Agent Desktop Add-on (AD) in Cloud for Service
- Upon confirming any Business Partner (Contact, Individual Customer, Account) or object like Ticket, AD throws the "Error: Contact List Data Load failed"
- While debugging in Chrome, one could notice a 403 error and the Response:"message": "Access to resource is unauthorized. Verify and try again."
Environment
- SAP Cloud for Service
- SAP Cloud for Sales
- Agent Desktop
Reproducing the Issue
- Go Services -> Agent Desktop
- Search and confirm a Business Partner
Cause
- Missing or incorrect configuration
- Missing Contact Work Center assignment to business role or user attributes
Resolution
- Go to Administrator -> General Settings -> Business Roles
- Open the Business Role assigned to the affected user
- Under the Work Center and View Assignments, search for the "COD_CONTACT_WCV" work center and click the checkbox, under the Assign to Business Role
- Save the changes, and Update Users (Assign Users -> Update Users)
- Test with the affected user
Keywords
Error, AD, Agent Desktop, Contact List, Contacts , KBA , LOD-CRM-SBS-AC , Agent Console Add-on , Problem
Product
SAP Cloud for Customer core applications 2302