Symptom
- You are using the Agent Desktop Add-on in Cloud for Service
- Agent desktop does not clear notes when searching for a Business Partner (BP), while using the Interaction Log functions
- You are expecting that after changing and confirming another BP, the notes would also be removed
Image/Data is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP Cloud for Service
- SAP Cloud for Sales
- Agent Desktop
Reproducing the Issue
- Go to Service -> Agent Desktop
- Search for a Business Partner (BP) and confirm
- Under the "Interaction Logs" tab, enter some data and enter some text in the Notes field
- Save
- On the upper-right corner, click the "Change Partner"
- Search for a new BP and confirm (you will notice that the text in the notes is not cleared)
Cause
- Since the system uses multisession, the notes/context information should remain even when changing BPs
- The system is working as designed
Resolution
- Agents need to use the Create Session button, instead of using the Change Partner
- The Change Partner option was designed for Agents to use in case the initial customer identification was wrong customer, this option opens the customer search screen to find and select another customer.
- Please note that such issues would not happen with real-time interactions such as Phone calls, SMS, Chats etc.
Keywords
AD, Notes, Interaction Logs, Manual Interactions, , KBA , LOD-CRM-SBS-AC , Agent Console Add-on , Problem
Product
SAP Cloud for Customer core applications 2305