Symptom
- Candidates cannot accept data privacy statement.
- External candidates cannot create a candidate profile due to no response upon clicking "Read and accept the data privacy statement".
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Go to external career site
- Create an account
- Click "Read and accept the data privacy statement."
- No response
Cause
The deprecated DPCS 1.0 is enabled in Provisioning.
Resolution
Data Privacy Consent Statement 1.0 has reached End of Maintenance on November 19, 2021 and was deleted on May 20, 2022.
Please disable the DPCS 1 options in Provisioning > Edit Candidate Privacy Options as below. Once it is disabled, candidates will be able to create new accounts.
To enable Data Privacy Statement, please engage an Implementation Partner or an SAP Authorized Partner to implement DPCS 2.0.
If you are no longer working with an Implementation Partner, please check the following KBA regarding how to raise a change request to SAP Support team.
- KBA 3142188 - Recruiting Sunset of DPCS 1.0 and how to migrate to DPCS 2.0 - Beginning H2 2021 Release
Note: SAP Support will only perform the switch from DPCS 1.0 to DPCS 2.0 on the back end and remaining configurations should be performed by the customer.
See Also
- SAP SuccessFactors What's New Viewer > Deprecation and Deleted Lifecycle > Deletion of Data Privacy Consent Statement 1.0
- KBA 2341240 - DPCS 2.0 - how to enable version 2.0 of Data Privacy Consent Statement and how to set up privacy statement - Recruiting Management
Keywords
DPCS, Data Privacy Consent Statement, DPCS 1.0, DPCS 2.0, career portal, candidate, create an account, career site , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , LOD-SF-RCM-POR , Career and Agency Portals , Problem