SAP Knowledge Base Article - Public

3342620 - Complete Delivery Indicator and Delivery Rule are not Taken Over From the Payload When Creating a Service Order via the Web Service

Symptom

You are creating a Service Order via the web service ManageServiceOrderIn and you are passing the Complete Delivery Indicator and Delivery Rule on Header level.

However, no matter what values you are passing in the DeliveryTerms via the payload on header level, the Complete Delivery Indicator is always set to true and the Delivery Rule is always set to Single delivery - full quantity (3)

Environment

SAP Business ByDesign

Reproducing the Issue

The following values can be passed for the Delivery Rule (PartialDeliveryControlCode):

1 = Multiple Deliveries;
2 = Single on-time delivery;
3 = Single delivery - full quantity;
8 = Single on-time delivery - full quantity;
9 = Single delivery

In our example we are using 1 for Multiple Deliveries:

You are passing the Delivery Terms with the Delivery Rule (PartialDeliveryControlCode) as Multiple Deliveries (1) and the Complete Delivery Indicator (CompleteDeliveryRequestedIndicator) as false (not checked) via the payload on header level:

           <DeliveryTerms>

               <DeliveryPriorityCode>1</DeliveryPriorityCode>

               <PartialDeliveryControlCode>1</PartialDeliveryControlCode>

               <CompleteDeliveryRequestedIndicator>false</CompleteDeliveryRequestedIndicator>

            </DeliveryTerms>

  1. Go to the Service Orders work center.
  2. Select the Service Order Processing view. 
  3. Open the Service Order that was created via the web service. 
  4. Navigate to the General tab and the Main Information sub tab. 
  5. In the in the Delivery section you can see that the 
  6. You expected that the Complete Delivery is not checked (false) and the Delivery Rule is Multiple Deliveries (1) since this was passed via the web service. 

Cause

  1. Open the Account Master Data of the Ship To Party of the Service Order.
  2. Navigate to the Sales Data tab.
  3. Select the Sales Organization and Distribution Channel that is selected in your Service Order in the Pricing and Invoicing tab and the Invoicing sub tab.
  4. You can see that the Complete Delivery Indicator is checked (true).

There is an additional check for Service Orders which will check the settings maintained in the Account Master Data for the Sales Organization and Distribution Channel and if the Complete Indicator is checked in the Account Master Data of the Ship To Party this will take precedence and therefore the CompleteDeliveryRequestedIndicator passed via the payload is disregarded.

Resolution

If you want to pass the Delivery Rule (PartialDeliveryControlCode) and the Complete Delivery Indicator (CompleteDeliveryRequestedIndicator) via the payload you need to ensure that the Complete Delivery Indicator is not checked in the Account Master Data of the Ship To Party used in the Service Order.

Keywords

Complete Delivery Indicator; Delivery Rule; Delivery Terms; webservice; DeliveryTerms; PartialDeliveryControlCode; CompleteDeliveryRequestedIndicator; Service Order , KBA , AP-SVO-SO , Service Order , Problem

Product

SAP Business ByDesign all versions