Symptom
In Import monitor the imports of updating contacts are ends with error "System failure in the enqueue server: Locking of object not permitted Contact(s) locked. Update is currently not possible"
Environment
SAP Marketing Cloud
Reproducing the Issue
- Upload contact or interaction or permission details which needed to be updated
- Update again for the same contact or interaction or permission while the previous import is in process.
- Check the import monitor for the error.
Cause
When there is a parallel update to interactions or permissions or the contacts while the contact update is being processed, It cause the error.
Resolution
Generally contact will be locked(when there is a parallel update to interactions or permissions or the contacts while the contact update is being processed).
So this cannot be controlled from Marketing end but parallel updates to the same contacts has to be taken care to avoid such locking issues.
For any lock error at a particular time , we should be able to find a success record at the same time for the same contact ( Either to Contact itself or its interactions or permissions ). So when update happens from different systems , Please make sure there is no parallel updates to the same contacts.
Keywords
Lock. , KBA , CEC-MKT-DM-IC , Interaction Contact , Problem
Product
SAP S/4HANA Cloud 2302