Symptom
- Candidate completed US I-9 Section 1 task, but e-signature step did not trigger.
- Candidate landed in BPE error after completing US I9 section task
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Candidate completes the US I9 Section 1 Task
- e-Signature step is not triggered.
- Error is generated in BPE: Monitor Process
Cause
The candidate managed to pass I9 Section 1 page without entering citizenship status.
Resolution
WORKAROUND:
- Navigate to Manage Data > I-9 User Data
- Enter the candidate's User Id
- Take Action > Make Correction
- In the 'Citizenship Type', choose the correct citizenship status for the candidate.
- Save
- Once done, go to BPE: Monitor Process
- Filter by 'Variable' and enter userId=[candidate's userId]
- Copy the Job Id of the error under the Job's section
- Then, in BPE: Manage Process Tasks, filter and enter the Job Id copied from step 8
- Finally, restart the task
PERMANENT FIX:
- Engineering is aware of this and is working on a code-fix.
- This KBA will be updated once the code correction ticket has been created.
Keywords
I9, US I9, Section 1, Compliance, e-signature , KBA , LOD-SF-OBX-I9 , i9 Compliance Form , Bug Filed
Product
SAP SuccessFactors Onboarding 2305