SAP Knowledge Base Article - Public

3343011 - I-9 Section 1 e-Signature Step did not trigger for a candidate - Onboarding

Symptom

  • Candidate completed US I-9 Section 1 task, but e-signature step did not trigger.
  • Candidate landed in BPE error after completing US I9 section task

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Candidate completes the US I9 Section 1 Task
  2. e-Signature step is not triggered.
  3. Error is generated in BPE: Monitor Process

Cause

The candidate managed to pass I9 Section 1 page without entering citizenship status.

Resolution

WORKAROUND:

  1. Navigate to Manage Data > I-9 User Data
  2. Enter the candidate's User Id
  3. Take Action > Make Correction
  4. In the 'Citizenship Type', choose the correct citizenship status for the candidate.
  5. Save
  6. Once done, go to BPE: Monitor Process
  7. Filter by 'Variable' and enter userId=[candidate's userId]
  8. Copy the Job Id of the error under the Job's section
  9. Then, in BPE: Manage Process Tasks, filter and enter the Job Id copied from step 8
  10. Finally, restart the task

PERMANENT FIX:

  • Engineering is aware of this and is working on a code-fix.
  • This KBA will be updated once the code correction ticket has been created.

Keywords

I9, US I9, Section 1, Compliance, e-signature , KBA , LOD-SF-OBX-I9 , i9 Compliance Form , Bug Filed

Product

SAP SuccessFactors Onboarding 2305