Symptom
Getting an error "Your work has not been saved! Please correct the errors below." but there is no message indicating which required field is missing on the page.
This KBA will introduce a way to troubleshoot the error.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Go to Recruiting > Job Requisitions
- View Job Req ID # > Candidate Summary
- Edit a candidate's job application
- Click Save button
- It shows "Your work has not been saved! Please correct the errors below." while all required fields on the page are filled
Cause
- A non-editable standard field is set as required="true".
- No write permission to Candidate Profile Background Element section(s) or More Information section.
Resolution
To find out which field(s) is/are causing the error, you can use the Dev Tool in your browser:
- First of all, make sure you have filled in all the other required fields on the page.
- Launch the Dev Tool before you click the Save button.
- You can launch the tool by Right-Clicking on the page and select 'Inspect'.
- The tool is available in all the browsers. Check the following KBA for reference: 2465224 - Creating an http traffic profile using Google Chrome's Developer Tools.
- Switch to the Network tab on the Dev Tool.
- Click the Save button on the Job Application page.
- You will see logs appearing upon clicking.
- Click to view the first row which shows "applicantProfileControllerProxy.saveApplicantProfileAndLog.dwr".
- View the Response tab.
- There it will list all the missing required fields. Check the fieldId.
For example, a possible misconfiguration is that you may have set the Candidate Profile Template standard field "employeeId" as required="true".
"employeeId" is a non-editable standard field so you will need to change it to required="false".
Here is how the field will look like in the response tab:
s1.errorKey="Field is required.";
s1.errorType="CANDIDATE_INFO_FIELD";
s1.fieldId="employeeId";
See Also
Please see the following KBA for solutions in different scenarios.
- KBA 3102544 - Updating Job Application results in an error: "Your Work Has Not Been Saved! Please correct the marked fields below" - Recruiting Management
Keywords
Candidate, Application, candidate profile, required, mandatory, employeeId, missing, is required, save, error, unable to update , KBA , LOD-SF-RCM-APP , Applicants and Job Applications , Problem