Symptom
You find the workflow doesn't execute when there is no Contact maintained for the related Business Partner.
Environment
SAP Cloud for Customer
Reproducing the Issue
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Go to the Administrator work center.
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Go to the Workflow rules view.
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Open workflow rule 123(where 123 is workflow rule ID).
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The Workflow Rule has been configured with no conditions and set to execute On Every Save.
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As a result, you find though you make a change on the Object, the workflow rule is not executed.
Cause
There is no Contact maintained for the Business Partner.
Example:
Recipient Determination for this workflow is:Contact of Account or Individual Account for Ticket
You make a change on the the Ticket, if currently there is no Contact maintained for the Customer in the Ticket, the workflow rule will not execute.
Resolution
This is the system design behavior.
See Also
Maintained Contact;Recipient Determination;execute On;
Keywords
Maintained Contact;Recipient Determination;execute On; , KBA , LOD-CRM-WKF , Workflow , How To