Symptom
During Importing Collection some apps cannot be accessed and Short Dumps occur
Environment
SAP S/4HANA Cloud
Reproducing the Issue
1. Connect in your Productive Environment.
2. Some tiles are tagged with Error.
3. While trying to use apps with error, SHORT DUMP occurs.
Cause
The detailed reason for this error is explained in the dump itself:
"During a system upgrade and for a short time period thereafter services based on SADL may not be available due to ongoing ABAP dictionary activations. The service in question is unavailable and will produce an ABAP runtime error when accessed."
Resolution
The only solution is wait until the system upgrade has completed before reattempting the previous operation. Depending on the system load this state will last for several minutes or even up to a few hours (under high load) after the upgrade. Please check: Import Collection: Business Impact and Dependencies
See Also
Keywords
Fiori, Apps, Error, Dump, CX_SADL_CDS_ACTIVATION_PENDING, CX_SADL_SHORTDUMP, Upgrade in process, activation is pending , KBA , BC-DWB-DIC , ABAP Dictionary and ABAP CDS , Known Error