SAP Knowledge Base Article - Public

3343521 - Bank statements cannot be posted automatically after being imported via API BankStatementPost_In

Symptom

  • Bank statements cannot be posted automatically after being imported via API BankStatementPost_In.
  • The bank statement is in 'Received' status in the application 'Manage Bank Statements.
  • The line items doesn't appear in the application 'Reprocess Bank Statement Items'.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

Import bank statements via the API BankStatementPost_In and check for the issue in the 'Manage Bank Statements' app.

Cause

The problem arises because the PostInBackground parameter has not been included in the service message header.

Resolution

  • It is supported to post bank statements asynchronously in the background by using the PostInBackground parameter in the service message header. See Bank Statement - Post and BankStatementPost_In - MessageHeader for more details.
  • If the imported bank statement is in 'Received' status, click on the 'Post' button in the app 'Manage Bank Statements'.

Keywords

BankStatementPost_In, import bank statement, API, automatically, Received, Post in background, Post, Manage Bank Statements, Reprocess Bank Statement Items, Bank Statement - Post , KBA , FI-BL-PT-BA-2CL , bank statement (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions