Symptom
Upon updating the field Authorization Group in the app Manage Business Partner Master Data, the Language Key was changed to Blank without any particular action.
Environment
SAP S/4HANA Cloud
Reproducing the Issue
- Go to the app Manage Business Partner Master Data
- Find and open the Business Partner ID
- In the tab Basic Data, in the General information, change the existing Authorization Group
- Save
- Go to the app Maintain Business Partner
- Find and open the Business Partner ID
- Click on Extras->Change History->For this Partner
- Select all the fields for which you want to see the change history and select Continue
- Correspondence Language (BUT000-LANGU_CORR) is set to blank. That is, the existing language in the field get wiped out.
Cause
Technical inconsistencies in the backend.
Resolution
In response to the reported issue, a software correction will be deployed on all the customer systems with 2308CE which is tentatively scheduled in August 2023.
Keywords
Language Key, Business Partner, Language, Authorization Group, Correspondence Language, Maintain Business Partner, Authorization Group, Deleted, Blank, Empty , KBA , LO-MD-FIO-BP , Fiori UI for Business Partner , Problem
Product
SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions