SAP Knowledge Base Article - Public

3343835 - Not able to see workflow details of custom object on Mobile app

Symptom

  • When trying to access the workflow details page of a custom object via the mobile app, it shows the message "Fail to Fetch Data".
  • Not able to see the workflow details of a custom object on mobile app.

“Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.”

Environment

  • SAP SuccessFactors HXM Suite
  • SAP SuccessFactors Mobile

Reproducing the Issue

  1. Login into the mobile app 
  2. Under the Approvals section on the Home Page, go to the desired Approval / Workflow
  3. You will be redirected to another screen with the following message: "Fail to fetch data"

Cause

Currently mobile is using workflow rest API to fetch detailed workflow data which requires Employee Central V2 to be enabled on the instance. If it is disabled, it won't be supported to view workflow detail page on mobile.

Resolution

If the instance does not have Employee Central V2 enabled, the workflow details are visible only on web.

Keywords

Workflow details, mobile, custom object, fail to fetch data , KBA , LOD-SF-PLT-MOB , Mobile Issues , How To

Product

SAP SuccessFactors HXM Core 2305