Symptom
- The customer is using the Local Adapter Integration scenario
- Users claim that after a call is alerted, although the customer phone number is correct, there is no search results
- Customer is using the Utilities Scenario with the Live Activity (Configure Live Activity Settings)
Environment
- SAP Service Cloud
- SAP Sales Cloud
- Live Activity
- SAP Local Adapter
Reproducing the Issue
- Connect to your Service Cloud tenant
- Initiate an inbound call
Cause
- Incorrect payload
- The customer is passing incorrect values in the Custom_1, Custom_2, Custom_3 or Custom_4 parameters
Resolution
- Ensure your CTI is passing the correct payload values to narrow down your search.
- If all criteria match, there will be only one open account/business partner (BP) and the customer hub will open automatically, eliminating the need to confirm the account.
- Depending on your configuration, incorrect values in any of the custom_* parameters can disrupt the search and yield unexpected results.
- For example, if all four custom parameters are utilized, and Custom_1 is mapped to Contract Account Number, passing more parameters will narrow down the search.
- If the passed parameter values exactly match, such as Contract Account Number = 220014546127, there will be a unique match, eliminating the need to select BPs from a list.
- Incorrect parameter values will disrupt the search. For instance, if Custom_1 (meant for account number) is filled with a different value like "John Doe," no match will be found. However, if the parameter is empty or not passed, the system will function as expected.
- If all parameter values are correct, including Custom_1, a unique hit will be obtained.
- If "Custom_1" is null or not passed, the system will also operate as expected, and provide the user with options to choose from the list
See Also
Keywords
CTI payload, Criteria matching, Custom parameters, Narrowing search, Exact value matching, Incorrect parameter values, Empty parameters, Unique hit, Contract Account Number, Customer hub auto-open. , KBA , LOD-CRM-LA , Live Activity , LOD-CRM-IND-UTL , Utilities , Problem
Product
SAP Cloud for Customer core applications 2305