SAP Knowledge Base Article - Public

3343909 - Ad Hoc notification token <STUD_NAME/> is not reflecting correct student name - SuccessFactors Learning

Symptom

  • Receive ad hoc notification but user name is blank
  • Receive ad hoc notification but user name is not full name
  • Receive ad hoc notification but user name differs with different locales

Environment

SAP SuccessFactors Learning

Reproducing the Issue

1. Add New Email Notification Template with AD_HOC_NOTIFICATION token set

2. Edit the notification template body and add token <STUD_NAME/>

3. Send email notification manually with this ad hoc template

4. Receive the notification but token <STUD_NAME/> is blank or not user's full name.

5. Change locale and reproduce the steps. Token <STUD_NAME/> is then displaying different value.

Cause

Label Value of format.LastName.FirstName.MI has been modified in certain locale.

Token <STUD_NAME/> fetches data according to format.LastName.FirstName.MI.

Thus, token <STUD_NAME/> may reflect to different values.

e.g. User doesn't have middle name.

Value of format.LastName.FirstName.MI has been modified to \{2\}. (only middle name)

As a result, he/she will be receiving notification with token <STUD_NAME/> as blank.

Resolution

Please edit the label value of format.LastName.FirstName.MI in the corresponding locale.

Note: 

\{0\}, \{1\} \{2\} = LastName, FirstName MiddleName

e.g. First Name MiddleName and Last Name =  \{1\} \{2\}, \{0\}

See Also

2670640 - How to change the Name Format of users in a particular language/locale - [LMS]

Keywords

SF, Success Factors, LMS, Change name format, first name, last name, middle name, ad hoc token, blank, full name , KBA , LOD-SF-LMS-NOT , Notifications , LOD-SF-LMS-LAN , Language Packs & Translation , Problem

Product

SAP SuccessFactors Learning all versions