Symptom
There are too many messages in the "In-Process" tab of the Import Monitor, and they are not processed.
Environment
SAP Marketing Cloud
Reproducing the Issue
- Import records;
- Observe that there are a lot of messages in the In-Process tab of the Import Monitor that are not processed;
- In some cases, the messages are stuck in-process for more than 3 days.
Cause
- Likely, a blocking situation occurs or temporary error happens on import, then system restarts it later for a few times and message stays in-process.
- If a huge number of single package payloads are imported to the system.
- Messages can be stuck in-process for more than 3 days in overload situations (= more than 500.000 payloads are waiting in the import queue) when the payloads are no longer sorted by their creation date, i.e. the staging area handler just reads and processes the next available payloads from the database regardless of their creation date, so as not to make the overload situation worse.
Resolution
- System will try to reprocess the imports several times for the next 3 days. If the maximum restart time is reached or 3 days passed, system will remove the payload from "In Process" to "Error" queue.
- Stop/reduce the sending of single payloads.
- Follow these recommendations to optimize the importing process. Best Practices and Recommended Package Sizes
- For Interactions API, monitor the daily health check that verifies if there are too many API calls for importing interactions that contain only one record. Health Check - Checking for Single API Calls for Interactions
See Also
Keywords
In-Process messages in import monitor, record stuck in In-Process tab of import monitor, record stuck in import monitor, records are In-Process, messages are In-Process tab of import monitor for long time. , KBA , CEC-MKT-DM-IC , Interaction Contact , CEC-MKT-DM-IA , Interaction , How To
Product
SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions