SAP Knowledge Base Article - Public

3344941 - Custom Query not Showing the Expected Results

Symptom

You create a custom query, that is not showing the correct results. The OVS field selection is not maintained for this custom query.

Environment

SAP Cloud for Customer.

Reproducing the Issue

It can happen to any object that contains an OVS field, but let's use Products and Product Category ID as an example:

  1. Go to Products Work center -> Trigger the custom query -> Nothing is shown. 
  2. After opening the advanced search and manually trigger the custom query, the results will be displayed. Example: clicking in the field "Product Category ID" > and select value e.g. "1.4" to trigger the expected filtered query.

Cause

The root cause for the issue is that the customer uses a product category with a leading space. There is a product category "1.4".

When the user selects the product category ID from the value help, the system uses "1.4". However, the system stores the value as "1.4" in the default set "Campaign Test Lens Products".

This leads to deviating results in the product query.

Resolution

You can open advanced search and check that when you set value manually, there is a space within the value.

Values with leading spaces should be avoided. This is a limitation, as the system does not support recognition and disregard of leading spaces.

Keywords

Query; Showing; Results; Manually; OVS; Selection; Custom; Query. , KBA , AP-RC-UIF-RT , UI Framework Runtime , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2302