Symptom
You Face Different Results According To The Use Of Capital Letter While Searching.
Environment
SAP Cloud for Customer
Reproducing the Issue
Let's use products as an example of object, but this can be applied to other objects as well:
1. Login using Sales Cloud Windows App in Offline Mode
2. Go to Products OWL and search for *ÖL*
3. Result: All products that contain "ÖL" in the name are found.
4. Change search to *öl*
Result: All products are not found anymore.
5. Searching for products in the work center products in the same way, The search results in offline mode is different for:
*Öl* - Result: 222
*öl* - Result: 18
Online, the search works correctly, no matter whether the search term is in upper or lower case.
It returns the same search results no matter if capitalized or not.
Cause
This is an expected behavior in offline. The device on which the app is running has only a limited set of resources. Therefore, it is required to use a different and limited database technology in offline compared to online. In this case the database only supports case-insensitivity while performing a full text search for the standard ASCII characters which does not include the extended ASCII characters (ö and Ö).
Resolution
This is a limitation due to technical restrictions on the devices.
Keywords
Different; results; capital letter; filter; search; offline; mobile. , KBA , AP-RC-MOB-OFL-RT , Offline Runtime , Problem