SAP Knowledge Base Article - Public

3345380 - Business Rule to Trigger Custom Email is Not Working - Onboarding

Symptom

The rule to trigger custom email after completing the Personal Data Collection step is not working.

The rule has additional condition to check candidate last name for example. 

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors Onboarding

Cause

Rules for MDF Objects scenario is run on today's context, hence future personal information is not fetched.

Resolution

To further filter email based on name or any other such criteria, please use existing feature of creating business rule to filter email templates. Refer to the following guide on how to create the Business Rule: Creating a Business Rule for Filtering Email Templates | SAP Help Portal 

Below is an example configured in SAP's Demo:

Keywords

Business, rule, custom, email, personal, information, Filter, email, template, Rules, for, MDF, Objects, effective, dated, Job, information, employment, information, rule, email, trigger, onboarding, onb, obx , KBA , LOD-SF-OBX-EML , Notifications , Problem

Product

SAP SuccessFactors Onboarding all versions