Symptom
You are trying to update employee schedules by directly modifying schedule template policies.
You are finding that these changes do not make it to the timesheets though, and many seemingly still use the old version of the policy. This may appear to resolve itself after a couple periods, but may appear again on seemingly random timesheets.
Environment
SAP Time and Attendance Management by WorkForce Software (all versions)
Cause
Any timesheet that has already been created and saved will stay with the old version of the schedule template have this issue.
Newly created timesheets will have the updated schedule, which means that this will generally correct itself over time. But if a timesheet is created in the future such as due to a time off request, that schedule will not update with any changes to the template.
Resolution
If just a few employees and templates are affected, you can re-assign the schedule template to the employees.
- From the Home screen, under Schedules, choose Assign Schedules.
- Under Permanent Changes, choose Assign Schedule Templates.
- Select the assignment group that contains the employee(s) whose schedule template has been updated.
- Change the employee's schedule template to None, then save your changes.
- Change the employee's schedule template back to the previous schedule template, then save your changes again.
For more information, please have a look at the below link
https://workforcesoftware.my.site.com/customers/s/article/Schedule-Changes-Made-on-Schedule-Template-Policy-Are-Not-Reflected-On-Employee-s-Schedule
Keywords
Template, assignment, schedule, changes, timesheet, TAM , KBA , XX-PART-WFR-TAM , SAP Time and Attendance Management by Workforce Software , Problem