Symptom
- When trying to Install SAP Sales Cloud, server side integration for Microsoft Outlook error "ISA-059: The request is invalid" is received.
- When trying to Enable Synchronization to newly provisioned user the error "The following configuration settings are invalid: ExchEWSUrl, ExchMailboxId. Please ensure that connection to user's mailbox is configured correctly." is shown.
- Sync fails for an object. The error in the groupware statistics logs is 'ISEC-005: Authentication error. The request failed. The remote server returned an error: (401) Unauthorized.'
Environment
- SAP Service Cloud v2
- SAP Sales Cloud v2
Reproducing the Issue
- Open Settings.
- Go to Groupware screen.
- In the users tab open the affected user.
- Click on the configuration button and select Enable Synchronization.
- Result: "The following configuration settings are invalid: ExchEWSUrl, ExchMailboxId. Please ensure that connection to user's mailbox is configured correctly."
- Now click on "Install SAP Sales Cloud, server side integration for Microsoft Outlook".
- Result: "ISA-059: The request is invalid".
Cause
In the User's settings page, the Mailbox Status is Not Initialized. This means the affected user did not initialize the e-mail in Groupware User Settings.
Resolution
Before it is possible to enable sync or install the outlook sever side it is necessary that the provisioned users follow below steps:
1. Open the navigation menu and go to Groupware User Settings.
2. Click on My Sync Status.
3. In Email configuration section click on Change.
4. Select the e-mail access type (e.g Office 365) and log on to the account.
After that, the administrator can install the outlook server side and enable sync for the user.
In case the user is using Google Direct Logon as mailbox access type, there are some additional steps to set up the Gmail Integration. Please refer to below steps:
1. Open the navigation menu and go to Groupware User Settings.
2. Click on My Sync Status.
3. In Email configuration section click on Change.
4. Choose Google.
5. In the window that appears, log on to the Google account and allow access.
6. Click on Tenant Settings
7. Under the Server-side integration for Outlook and Gmail section, click on the link 'Server-side integration for Gmail'
8. The Google Chrome Web Store opens to the correct extension.
9. Add the extension.
10. In Chrome browser, select the three dots option at the top-right corner and then More tools -> Extensions.
11. Enable the extension that was just added.
12. The tenant URL is automatically mapped to the SAP Sales Cloud Version 2 for Gmail extension.
After this, the SAP sales cloud add-in will be available in the Gmail, so it's not necessary to click on the 'Install add-in' button.
See Also
Help Documentation: Manage User Provisioning
Keywords
Outlook Server Side, Enable Synchronization, The request is invalid, ExchEWSUrl, ExchMailboxId , KBA , CEC-CRM-GW , Groupware for SAP Sales/Service Cloud , How To
Product
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