Symptom
Not able to alter the Order Custom Field permission via REST API for newly created Order Status.
Environment
SAP SALES CLOUD CPQ
Reproducing the Issue
- Create a quote custom field;
- Call GET /api/quote/v1/quoteCustomField/{quoteCustomFieldId}/permissions to verify the custom field has all permissions generated;
- Create a new Order Status;
- Call GET /api/quote/v1/quoteCustomField/{quoteCustomFieldId}/permissions to verify the custom field does not have permissions generated for newly added Order Status;
- Call POST /api/quote/v1/quoteCustomField/{quoteCustomFieldId}/permissions to set permissions for newly added Order Status:[ { "userTypeId": {anyUserTypeId}, "orderStatusId": {newlyAddedOrderStatusId}, "value": "Editable" } ];
- Check that if not passing Permission ID, API do not work.
Cause
Expected Behavior.
Only updating existing permission is allowed via this endpoint.
Resolution
Customer should set permissions first in the UI to be able to modify through API call.
Keywords
Quote Custom Field, Permission, QCF, Workflow, Order Status, CPQ , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Bug Filed
Product
SAP CPQ 2023