SAP Knowledge Base Article - Public

3345944 - onInit rule configured to raise message is not working - Employee Central

Symptom

You have created a business rule to trigger a message following the guide instructions but it's not working.

Environment

SAP SuccessFactors Employee Central

Cause

Raise message rules are currently not supported with onInit event type.

Resolution

This is expected behavior.

onInit event is designed to be used to "set field properties (for example, making fields mandatory, or hiding fields), or to default values that you want to be shown as soon as the user calls up a page." Please refer to the Event Types for HRIS Elements and HRIS Fields guide. You can use onChange or onSave event types to raise messages instead.

See Also

Keywords

raise message, oninit, onchange, onsave, warning message, severity, event, event type, hris element, rule, not working, trigger, triggering, rule trace, not triggering, employee central , KBA , LOD-SF-EC-BCI , Manage Business Configuration (BCUI) & Data Models (XML) , How To

Product

SAP SuccessFactors Employee Central all versions