Symptom
You are looking forward to create a custom field (i.e. extension field) of 'Note' type, however you could not see 'Note' option to be selected during creation of the custom field.
Environment
- Service Cloud Version 2
- Sales Cloud Version 2
Reproducing the Issue
- Click on User Profile.
- Click on Settings.
- Select All Settings.
- Go to Extensibility Administration.
- Select Extensibility.
- Select an Entity (e.g. Case).
- On Custom Fields tab, click on Create Custom Field.
- You can't select Note type.
Cause
The system supports these following Data Types to create custom fields (i.e. extension fields):
- String
- Number
- Boolean
- Object
- Integer
- Date Time
Resolution
For creating an extension field which acts like a note field and stores many characters, you may use String for either Data Type and Data Format options. Then, you can specify Field Length as per your business requirement and you will have an extension field which can store text values.
See Also
Keywords
extension field, custom field, note type, string , KBA , CEC-CRM-CZM-EXT , Extensibility for SAP Sales/Service Cloud , CEC-CRM-CZM , Customization for SAP Sales/Service Cloud , How To