SAP Knowledge Base Article - Public

3347427 - Unable to See Text Content Added to Email Body when Using Templates in Cases

Symptom

When you are writing an email in one of your cases, and you add a text content along with a template, if you click Preview or even send the email, you notice the text content is not visible.

Environment

SAP Service Cloud Version 2.

Reproducing the Issue

  1. Navigate to Cases work center.
  2. Open any case.
  3. Click Send Email.
  4. Select a Branding Template from the list of templates or click Add Templates and choose a Response Template.
  5. In the email editor, add any text content.
  6. Click Email Preview.
  7. The template is displayed, but the text content added to the email is not there.

Cause

When the templates are used in the emails, the same should be defined with a placeholder ##text##, which will specify where exactly the content should come up when the email is composed.

There is no limit on the number of characters that can be added to this placeholder, as the whole email body will be placed in this slot.

Resolution

To ensure the text contents written in the email are considered for the preview and when the email is sent out, make sure to use the placeholder ##text## in your templates when it is applicable.

Keywords

Template, Branding Template, Response Template, Email, Email Template, email preview , Case, Preview, Content, Email Content, Preview Template, Placeholder, ##text##, SAP Service Cloud Version 2,  , KBA , CEC-CRM-TMP , Templates for SAP Sales/Service Cloud , How To

Product

SAP Service Cloud Version 2 all versions