Symptom
Error "Getting error "Number XXXXX is already assigned to partner XXXXXX for ID type HCM001".
Environment
SAP Cloud for Customer
Reproducing the Issue
Try to update the employees via data workbench.
Cause
This Key is "only" known by the DWB-Tool and has nothing in common with the other Employee identifiers (as "EmployeeID", "BusinessPartnerInternalID", ...) from the service/BO. If this Employee initially created via the DWB-Tool this DWB-ExternalKey has to be supplied as IDENTIFIER (e.g. an already known ID from any other system) by the DWB-consumer.
There is also the possibility to UPLOAD for non-DWB-created Employees an DWB-ExternalKey.
This can be done via "DWB>IMPORT>IDMapping".
Here, a mapping between a newly specified DWB-ExternalKey and an existing "EmployeeID" needs to be uploaded.
Once this is done, a subsequent DWB>EXPORT of the Employee should also include the DWB-ExternalKey.
Afterward, this DWB-ExternalKey needs to be passed as identifier in your use-case for DWB>UPSERT_COMPLETE_BO.
(For "simple" update scenarios, we recommend the "standard" EXPORT>UPDATE cycle (via DWB>EXPORT and subsequent DWB>IMPORT>IndOBJ>UPDATE) instead of using UPSERT>CompleteBO.)
Resolution
Re-check the used file. This scenario is commonly related to the column "ExternalKey" in the template being filled.
Keywords
Error; number; assigned; partner; ID; type; External; Key; template , KBA , LOD-CRM-INT-DWB , Data Workbench , How To