Symptom
You created an email template with images and uploaded it as an .HTML file in the system, however, when using the Viewer or Preview functionalities, the images of the template are not properly displayed.
Environment
SAP Service Cloud Version 2.
Reproducing the Issue
- Click on the User Menu.
- Click Settings.
- Navigate to All Settings.
- Click Templates, under Emails.
- Select the template you have images added to the .HTML
- In the Viewer tab, see the images are not displayed properly.
Cause
The images added to the template .HTML file are coming from web URLs, meaning, their source are web addresses.
Due to the system security policies, the UI will not display images when they come from web sources.
Resolution
When the email where the template is used goes out, it will be receive with the images being displayed as expected, however, if you would like to also have the ability to see the images in the template Viewer tab and the Email Preview, it would be required to encode the images to base64 images, adjusting the .HTML template accordingly.
Keywords
Image, Images, Pictures, Icons, Template, Email Template, Response Template, Branding Template, Response, Branding, HTML, Web, base64, Encode, Encoding, SAP Service Cloud Version 2, Email, , KBA , CEC-CRM-TMP , Templates for SAP Sales/Service Cloud , CEC-CRM-EML , Emails for SAP Sales/Service Cloud , How To