Symptom
- iOS users get an error ~ device state unregistered ~ if they login successfully to the app then logout and try to login again. This does not occur on Android devices.
- An MS Azure error code 530001 shows up in the UI along with the device state unregistered message.
Environment
SAP SuccessFactors HXM Suite - Mobile
Reproducing the Issue
- Install Intune Company Portal
- Install SuccessFactors through Intune using an iphone
- Launch SuccessFactors app and connect by providing the user's credentials
- the connection is successful -> This is expected.
- Once connected, deactivate the account in SuccessFactors Mobile app and close the app. The deactivation is successful. -> This is expected.
- Launch again SuccessFactors mobile app and connect with the same user by providing its credentials. the login fails and an error message ~ device state unregistered ~ is thrown (screenshot attached) -> This is not expected.
Cause
This may be caused by a network restriction. Initially, creating a session through the App using Safari ViewController works fine. However, when the same flow is repeated and the app switches to a different ViewController using WebKit, the request gets blocked due to the network configuration.
Resolution
To workaround this issue, we recommend clearing the Safari cache and trying to access again.
Keywords
sf, sfsf , sf sf, SuccessFactors, SuccessFactor, Success Factor, bizx, Safari ViewController, iOS, MDM MS intunes, INC4998704 , KBA , LOD-SF-PLT-MOB , Mobile Issues , How To