SAP Knowledge Base Article - Public

3348009 - Subscriptions missing on Frontend(Fiori) contact profile

Symptom

Subscription with communication category is imported and relevant interaction can be found under contact profile. But subscriptions cannot be found under tab "Permission Marketing" on Frontend(Fiori) contact profile

Environment

  • SAP Marketing Cloud

Reproducing the Issue

  1. Import subscriptions with relevant communication category
  2. Check subscriptions under tab "Permission Marketing" on Frontend(Fiori) contact profile

Cause

Subscriptions are supported for the Email Newsletter Scenario only, so subscription support communication medium EMAIL only - technically you can import subscriptions for different comm medium and different ID origins, but during the subscription execution but also in the contact UI, only subscriptions created for the EMAIL scenario are considered. 

Resolution

You can only assign subscription-enabled communication categories to emails. Subscriptions only work with the communication medium Email, where the origin is EMAIL. You can't use any other origin, for example SMS or an origin you've created yourself.

See Also

This design is documented in the online help as well:

  1. Permissions and Subscriptions
    Subscriptions are a special form of permissions, which are only valid for a certain marketing context, for example, a newsletter or event. In contrast to permissions, there are no default subscriptions. Subscriptions are only available for the email communication medium. They can be overridden by opting out of general email permissions.
  2. Communication Categories and Limits

Keywords

opt in, opt out, permission, subscription. , KBA , CEC-MKT-DM-PER , Marketing permissions , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions