SAP Knowledge Base Article - Public

3348039 - Payment method cash is not found for a Customer Account

Symptom

You try to add 'Cash' payment method for a customer account and system throws error message 'cash is not a valid value for this field. Enter a valid value.'

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Receivables work center
  2. Customers view and search for the relevant customer and Click on customer name
  3. View all - Financial Data tab - Cash can be found under payment method, However when clicked on drop down, cash is missing and even system throws error message 'cash is not a valid value for this field. Enter a valid value.'

Cause

We currently do not support Cash and hence, not available in the payment method drop down.

Resolution

The payment methods section is meant to hold those internally initiated payment methods that we need to support in case of automatic payments for this specific customer account.

For a customer account, we would expect Direct Debit, Credit Card as the values.

It would still be possible to create an incoming cash payment from payment management work center for this specific customer account.

Keywords

Customer Account, Cash, Payment method , KBA , SRD-FIN-ACR , Receivables , AP-ACC , Business ByDesign: Financial Accounting , SRD-FIN-GL , General Ledger , Problem

Product

SAP Business ByDesign all versions