Symptom
You are changing a field in a specific Business Partner, such as Accounts or Individual Customers and you noticed the replication of contacts relationship service interface is not triggered.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Customer work center.
- Go to the Accounts work view.
- Search and open the Account ID 1234 (where 1234 refers to the Account ID).
- Perform a change on any field.
- Go to the Administrator work center.
- Go to the General Setting work center view.
- Open the Web Service Message Monitoring under System Administration
- Select query All
- Search for Account ID 1234
Behavior: There is no outbound service interface BusinessPartnerRelationship triggered.
Cause
This is the system design.
Therefore, if you change a field of the Business Partner, in this case, the account, the relationship messages aren't sent out.
Resolution
For triggering business partner relationship message, you need to create or change the relationship in the Business Partner. Please find the steps below:
- Go to the Customer work center.
- Go to the Accounts work view.
- Search and open the Account ID 1234 (where 1234 refers to the Account ID).
- Go to the Contacts facet.
- Click on "New" to create a new contact.
- Go to the Administrator work center.
- Go to the General Setting work center view.
- Open the Web Service Message Monitoring under System Administration
- Select query All
- Search for Account ID 1234
You noticed the BusinessPartnerRelationshipReplication message is triggered.
Keywords
Contact Replication; C4C; BusinessPartnerRelationship; Business Partner; Accounts; Contacts; , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , LOD-CRM-ACC , Account , How To