SAP Knowledge Base Article - Public

3348766 - Contact Relationship Replication Isn't Triggered after Changing Business Partner's Fields

Symptom

You are changing a field in a specific Business Partner, such as Accounts or Individual Customers and you noticed the replication of contacts relationship service interface is not triggered.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Customer work center.
  2. Go to the Accounts work view.
  3. Search and open the Account ID 1234 (where 1234 refers to the Account ID).
  4. Perform a change on any field.
  5. Go to the Administrator work center.
  6. Go to the General Setting work center view.
  7. Open the Web Service Message Monitoring under System Administration
  8. Select query All
  9. Search for Account ID 1234

Behavior: There is no outbound service interface BusinessPartnerRelationship triggered.

Cause

This is the system design.

Therefore, if you change a field of the Business Partner, in this case, the account, the relationship messages aren't sent out.

Resolution

For triggering business partner relationship message, you need to create or change the relationship in the Business Partner. Please find the steps below:

  1. Go to the Customer work center.
  2. Go to the Accounts work view.
  3. Search and open the Account ID 1234 (where 1234 refers to the Account ID).
  4. Go to the Contacts facet.
  5. Click on "New" to create a new contact.
  6. Go to the Administrator work center.
  7. Go to the General Setting work center view.
  8. Open the Web Service Message Monitoring under System Administration
  9. Select query All
  10. Search for Account ID 1234

You noticed the BusinessPartnerRelationshipReplication message is triggered.

Keywords

Contact Replication; C4C; BusinessPartnerRelationship; Business Partner; Accounts; Contacts; , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer core applications 1.0